在Rails3 出现这个错误,做以下工作:

  1. 在Gemfile
gem 'mysql2', '~> 0.2.6'

2.

bundle update
  1. 在datababse.yml
development:
  adapter: mysql2
  encoding: utf8
  database: devise
  # pool: 5
  username: root
  password:
  reconnect: true
  socket: /tmp/mysql.sock
  

参考: http://stackoverflow.com/questions/4297253/install-mysql2-gem-on-snow-leopard-for-rails-3-with-rvm

转载请注明:韦旭红的点点滴滴 » RuntimeError (!!! Missing the mysql2 gem. Add it to your Gemfile: gem ‘mysql2′):